const regex = /(\/{1}[a-z.0-9]+\/{1}$)|([0-9]+$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\/{1}[a-z.0-9]+\\\/{1}$)|([0-9]+$)', 'gm')
const str = `https://www.facebook.com/j2teamnnl/
https://www.facebook.com/groups/j2team.community/
https://www.facebook.com/profile.php?id=100048240755558
h//www.facebook.com/
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}