re = /(\/{1}[a-z.0-9]+\/{1}$)|([0-9]+$)/m
str = 'https://www.facebook.com/j2teamnnl/
https://www.facebook.com/groups/j2team.community/
https://www.facebook.com/profile.php?id=100048240755558
h//www.facebook.com/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end