import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/{1}[a-z.0-9]+\\/{1}$)|([0-9]+$)";
final String string = "https://www.facebook.com/j2teamnnl/\n"
+ "https://www.facebook.com/groups/j2team.community/\n"
+ "https://www.facebook.com/profile.php?id=100048240755558\n"
+ "h//www.facebook.com/\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}