import Foundation
let pattern = #"(,)(?=[^"]*"(?:[^"\r\n]*"[^"]*")*[^"\r\n]*$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
kol1,kol2,"kol3,kol3a",hhhh,"bb,bbb",kkff,ddd,"lll"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"{comma}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)