const regex = /(,)(?=[^"]*"(?:[^"\r\n]*"[^"]*")*[^"\r\n]*$)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(,)(?=[^"]*"(?:[^"\\r\\n]*"[^"]*")*[^"\\r\\n]*$)', 'g')
const str = `kol1,kol2,"kol3,kol3a",hhhh,"bb,bbb",kkff,ddd,"lll"
`;
const subst = `{comma}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);