re = /(,)(?=[^"]*"(?:[^"\r\n]*"[^"]*")*[^"\r\n]*$)/
str = 'kol1,kol2,"kol3,kol3a",hhhh,"bb,bbb",kkff,ddd,"lll"
'
subst = '{comma}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result