using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(,)(?=[^""]*""(?:[^""\r\n]*""[^""]*"")*[^""\r\n]*$)";
string substitution = @"{comma}";
string input = @"kol1,kol2,""kol3,kol3a"",hhhh,""bb,bbb"",kkff,ddd,""lll""
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}