# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(,)(?=[^"]*"(?:[^"\r\n]*"[^"]*")*[^"\r\n]*$)/{comma}/g;t' <<< "kol1,kol2,\"kol3,kol3a\",hhhh,\"bb,bbb\",kkff,ddd,\"lll\"
"