# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(,)(?=[^\"]*\"(?:[^\"\r\n]*\"[^\"]*\")*[^\"\r\n]*$)"
test_str = ("kol1,kol2,\"kol3,kol3a\",hhhh,\"bb,bbb\",kkff,ddd,\"lll\"\n")
subst = "{comma}"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.