$re = '/(,)(?=[^"]*"(?:[^"\r\n]*"[^"]*")*[^"\r\n]*$)/';
$str = 'kol1,kol2,"kol3,kol3a",hhhh,"bb,bbb",kkff,ddd,"lll"
';
$subst = "{comma}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;