#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(,)(?=[^"]*"(?:[^"\r\n]*"[^"]*")*[^"\r\n]*$)"
Local $sString = "kol1,kol2,"kol3,kol3a",hhhh,"bb,bbb",kkff,ddd,"lll"" & @CRLF & _
""
Local $sSubst = "{comma}"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)