import Foundation
let pattern = #"^\s*DO\s*[0-9]*\s*([A-Z])\s*=\s*1,\s*([0-9]+|[A-Z]+)\s*{*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
DO 2 I = 1, 56 {
DO L = 1, 56 {
DO M = 1, MM {
CALL S(M, A);//read new SFiles
DO K = 1, 91{
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"for ($1 = 0; $1 < $2; $1++) { "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)