re = /^\s*DO\s*[0-9]*\s*([A-Z])\s*=\s*1,\s*([0-9]+|[A-Z]+)\s*{*/m
str = 'DO 2 I = 1, 56 {
DO L = 1, 56 {
DO M = 1, MM {
CALL S(M, A);//read new SFiles
DO K = 1, 91{
'
subst = 'for ($1 = 0; $1 < $2; $1++) { '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result