import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*DO\\s*[0-9]*\\s*([A-Z])\\s*=\\s*1,\\s*([0-9]+|[A-Z]+)\\s*\\{*";
final String string = "DO 2 I = 1, 56 {\n"
+ " DO L = 1, 56 {\n"
+ " DO M = 1, MM {\n"
+ " CALL S(M, A);//read new SFiles\n"
+ " DO K = 1, 91{\n\n\n";
final String subst = "for ($1 = 0; $1 < $2; $1++) { ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}