use strict;
my $str = 'DO 2 I = 1, 56 {
DO L = 1, 56 {
DO M = 1, MM {
CALL S(M, A);//read new SFiles
DO K = 1, 91{
';
my $regex = qr/^\s*DO\s*[0-9]*\s*([A-Z])\s*=\s*1,\s*([0-9]+|[A-Z]+)\s*{*/mp;
my $subst = 'for ($1 = 0; $1 < $2; $1++) { ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";