# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*DO\s*[0-9]*\s*([A-Z])\s*=\s*1,\s*([0-9]+|[A-Z]+)\s*{*"
test_str = ("DO 2 I = 1, 56 {\n"
" DO L = 1, 56 {\n"
" DO M = 1, MM {\n"
" CALL S(M, A);//read new SFiles\n"
" DO K = 1, 91{\n\n\n")
subst = "for ($1 = 0; $1 < $2; $1++) { "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.