// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\s*DO\s*[0-9]*\s*([A-Z])\s*=\s*1,\s*([0-9]+|[A-Z]+)\s*{*").unwrap();
let string = "DO 2 I = 1, 56 {
DO L = 1, 56 {
DO M = 1, MM {
CALL S(M, A);//read new SFiles
DO K = 1, 91{
";
let substitution = "for ($1 = 0; $1 < $2; $1++) { ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}