#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^\s*DO\s*[0-9]*\s*([A-Z])\s*=\s*1,\s*([0-9]+|[A-Z]+)\s*{*"
Local $sString = "DO 2 I = 1, 56 {" & @CRLF & _
" DO L = 1, 56 {" & @CRLF & _
" DO M = 1, MM {" & @CRLF & _
" CALL S(M, A);//read new SFiles" & @CRLF & _
" DO K = 1, 91{" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "for ($1 = 0; $1 < $2; $1++) { "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)