const regex = /^\s*DO\s*[0-9]*\s*([A-Z])\s*=\s*1,\s*([0-9]+|[A-Z]+)\s*{*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*DO\\s*[0-9]*\\s*([A-Z])\\s*=\\s*1,\\s*([0-9]+|[A-Z]+)\\s*{*', 'gm')
const str = `DO 2 I = 1, 56 {
DO L = 1, 56 {
DO M = 1, MM {
CALL S(M, A);//read new SFiles
DO K = 1, 91{
`;
const subst = `for ($1 = 0; $1 < $2; $1++) { `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);