import Foundation
let pattern = #"(?:https:\/\/odysee.com\/@)(?<osChannel>\w+)((:[\w])?\/)(?<osVideo>[\w\-\'\%]+)(:[\w])?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://odysee.com/@MrBeat:1/the-gulf-war-explained:0
https://odysee.com/@MargauxAlvarez:f/teaching-the-squat-series:6
https://odysee.com/@NaomiBrockwell:4/Email-aliases:2
https://odysee.com/@NaomiBrockwell/Email-aliases
https://odysee.com/@surveillancereport:2/this-app-leaked-billie-eilish's-address:2
https://odysee.com/@surveillancereport:2/this-app-leaked-billie-eilish%27s-address:2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)