use strict;
my $str = 'https://odysee.com/@MrBeat:1/the-gulf-war-explained:0
https://odysee.com/@MargauxAlvarez:f/teaching-the-squat-series:6
https://odysee.com/@NaomiBrockwell:4/Email-aliases:2
https://odysee.com/@NaomiBrockwell/Email-aliases
https://odysee.com/@surveillancereport:2/this-app-leaked-billie-eilish\'s-address:2
https://odysee.com/@surveillancereport:2/this-app-leaked-billie-eilish%27s-address:2
';
my $regex = qr/(?:https:\/\/odysee.com\/@)(?<osChannel>\w+)((:[\w])?\/)(?<osVideo>[\w\-\'\%]+)(:[\w])?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}