# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:https:\/\/odysee.com\/@)(?<osChannel>\w+)((:[\w])?\/)(?<osVideo>[\w\-\'\%]+)(:[\w])?"
test_str = ("https://odysee.com/@MrBeat:1/the-gulf-war-explained:0\n"
"https://odysee.com/@MargauxAlvarez:f/teaching-the-squat-series:6\n"
"https://odysee.com/@NaomiBrockwell:4/Email-aliases:2\n"
"https://odysee.com/@NaomiBrockwell/Email-aliases\n"
"https://odysee.com/@surveillancereport:2/this-app-leaked-billie-eilish's-address:2\n"
"https://odysee.com/@surveillancereport:2/this-app-leaked-billie-eilish%27s-address:2\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.