#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:https:\/\/odysee.com\/@)(?<osChannel>\w+)((:[\w])?\/)(?<osVideo>[\w\-\'\%]+)(:[\w])?"
Local $sString = "https://odysee.com/@MrBeat:1/the-gulf-war-explained:0" & @CRLF & _
"https://odysee.com/@MargauxAlvarez:f/teaching-the-squat-series:6" & @CRLF & _
"https://odysee.com/@NaomiBrockwell:4/Email-aliases:2" & @CRLF & _
"https://odysee.com/@NaomiBrockwell/Email-aliases" & @CRLF & _
"https://odysee.com/@surveillancereport:2/this-app-leaked-billie-eilish's-address:2" & @CRLF & _
"https://odysee.com/@surveillancereport:2/this-app-leaked-billie-eilish%27s-address:2" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")