import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:https:\\/\\/odysee.com\\/@)(?<osChannel>\\w+)((:[\\w])?\\/)(?<osVideo>[\\w\\-\\'\\%]+)(:[\\w])?";
final String string = "https://odysee.com/@MrBeat:1/the-gulf-war-explained:0\n"
+ "https://odysee.com/@MargauxAlvarez:f/teaching-the-squat-series:6\n"
+ "https://odysee.com/@NaomiBrockwell:4/Email-aliases:2\n"
+ "https://odysee.com/@NaomiBrockwell/Email-aliases\n"
+ "https://odysee.com/@surveillancereport:2/this-app-leaked-billie-eilish's-address:2\n"
+ "https://odysee.com/@surveillancereport:2/this-app-leaked-billie-eilish%27s-address:2\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}