// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:https:\/\/odysee.com\/@)(?<osChannel>\w+)((:[\w])?\/)(?<osVideo>[\w\-\'\%]+)(:[\w])?").unwrap();
let string = "https://odysee.com/@MrBeat:1/the-gulf-war-explained:0
https://odysee.com/@MargauxAlvarez:f/teaching-the-squat-series:6
https://odysee.com/@NaomiBrockwell:4/Email-aliases:2
https://odysee.com/@NaomiBrockwell/Email-aliases
https://odysee.com/@surveillancereport:2/this-app-leaked-billie-eilish's-address:2
https://odysee.com/@surveillancereport:2/this-app-leaked-billie-eilish%27s-address:2
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}