using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:https:\/\/odysee.com\/@)(?<osChannel>\w+)((:[\w])?\/)(?<osVideo>[\w\-\'\%]+)(:[\w])?";
string input = @"https://odysee.com/@MrBeat:1/the-gulf-war-explained:0
https://odysee.com/@MargauxAlvarez:f/teaching-the-squat-series:6
https://odysee.com/@NaomiBrockwell:4/Email-aliases:2
https://odysee.com/@NaomiBrockwell/Email-aliases
https://odysee.com/@surveillancereport:2/this-app-leaked-billie-eilish's-address:2
https://odysee.com/@surveillancereport:2/this-app-leaked-billie-eilish%27s-address:2
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}