$re = '/(?:https:\/\/odysee.com\/@)(?<osChannel>\w+)((:[\w])?\/)(?<osVideo>[\w\-\'\%]+)(:[\w])?/m';
$str = 'https://odysee.com/@MrBeat:1/the-gulf-war-explained:0
https://odysee.com/@MargauxAlvarez:f/teaching-the-squat-series:6
https://odysee.com/@NaomiBrockwell:4/Email-aliases:2
https://odysee.com/@NaomiBrockwell/Email-aliases
https://odysee.com/@surveillancereport:2/this-app-leaked-billie-eilish\'s-address:2
https://odysee.com/@surveillancereport:2/this-app-leaked-billie-eilish%27s-address:2
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);