import Foundation
let pattern = #"((?:token|apikey|secret|client_id): )([a-zA-z0-9\-]+)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"entere config here"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1(removed)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)