re = /((?:token|apikey|secret|client_id): )([a-zA-z0-9\-]+)\b/mi
str = 'entere config here'
subst = '$1(removed)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result