using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:token|apikey|secret|client_id): )([a-zA-z0-9\-]+)\b";
string substitution = @"$1(removed)";
string input = @"entere config here";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}