# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:token|apikey|secret|client_id): )([a-zA-z0-9\-]+)\b/$1(removed)/gmi;t' <<< "entere config here"