use strict;
my $str = 'entere config here';
my $regex = qr/((?:token|apikey|secret|client_id): )([a-zA-z0-9\-]+)\b/mip;
my $subst = '$1(removed)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";