$re = '/((?:token|apikey|secret|client_id): )([a-zA-z0-9\-]+)\b/mi';
$str = 'entere config here';
$subst = "$1(removed)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;