import Foundation
let pattern = ##"2(\d{2})[\r\n](.{12})\s{2}(.{8})\s(.{8})[\r\n](.{31})[\r\n]\s*(\S*)\s*P#(.{12})[\r\n](.{31})[\r\n].*[\r\n]\s*(\S*)[\r\n]\s*(\S*)\s*(\S*).*[\r\n].*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*).*[\r\n]\s*(.{12}).*[\r\n](.{19}).*[\r\n].*"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
201
541-303-1291 05/28/20 13:29:55
MUNSELL,MAJORIE
865 P#541-303-1291
W RIDGEWAY AVE
ESN=06204
HERMISTON OR
CLASS:RESD TEL=CHTR
LAT: LON:
METERS: PERCENT:
ELV SPD DIR
PSAP=HERM
HERMISTON PD
UMATILLA COUNTY FD1
UMATILLA COUNTY FD1
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)