import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "2(\\d{2})[\\r\\n](.{12})\\s{2}(.{8})\\s(.{8})[\\r\\n](.{31})[\\r\\n]\\s*(\\S*)\\s*P#(.{12})[\\r\\n](.{31})[\\r\\n].*[\\r\\n]\\s*(\\S*)[\\r\\n]\\s*(\\S*)\\s*(\\S*).*[\\r\\n].*[\\r\\n]\\s*(\\S*)\\s*(\\S*).*[\\r\\n]\\s*(\\S*)\\s*(\\S*).*[\\r\\n]\\s*(\\S*)\\s*(\\S*).*[\\r\\n]\\s*(\\S*)\\s*(\\S*)\\s*(\\S*).*[\\r\\n]\\s*(\\S*).*[\\r\\n]\\s*(.{12}).*[\\r\\n](.{19}).*[\\r\\n].*";
final String string = "201\n"
+ "541-303-1291 05/28/20 13:29:55\n"
+ "MUNSELL,MAJORIE \n"
+ " 865 P#541-303-1291\n"
+ "W RIDGEWAY AVE \n"
+ " \n"
+ " ESN=06204\n"
+ "HERMISTON OR\n\n"
+ "CLASS:RESD TEL=CHTR \n"
+ "LAT: LON: \n"
+ "METERS: PERCENT: \n"
+ "ELV SPD DIR \n"
+ "PSAP=HERM\n"
+ "HERMISTON PD\n"
+ "UMATILLA COUNTY FD1\n"
+ "UMATILLA COUNTY FD1 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}