# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"2(\d{2})[\r\n](.{12})\s{2}(.{8})\s(.{8})[\r\n](.{31})[\r\n]\s*(\S*)\s*P#(.{12})[\r\n](.{31})[\r\n].*[\r\n]\s*(\S*)[\r\n]\s*(\S*)\s*(\S*).*[\r\n].*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*).*[\r\n]\s*(.{12}).*[\r\n](.{19}).*[\r\n].*"
test_str = ("201\n"
"541-303-1291 05/28/20 13:29:55\n"
"MUNSELL,MAJORIE \n"
" 865 P#541-303-1291\n"
"W RIDGEWAY AVE \n"
" \n"
" ESN=06204\n"
"HERMISTON OR\n\n"
"CLASS:RESD TEL=CHTR \n"
"LAT: LON: \n"
"METERS: PERCENT: \n"
"ELV SPD DIR \n"
"PSAP=HERM\n"
"HERMISTON PD\n"
"UMATILLA COUNTY FD1\n"
"UMATILLA COUNTY FD1 ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.