const regex = /2(\d{2})[\r\n](.{12})\s{2}(.{8})\s(.{8})[\r\n](.{31})[\r\n]\s*(\S*)\s*P#(.{12})[\r\n](.{31})[\r\n].*[\r\n]\s*(\S*)[\r\n]\s*(\S*)\s*(\S*).*[\r\n].*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*).*[\r\n]\s*(.{12}).*[\r\n](.{19}).*[\r\n].*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('2(\\d{2})[\\r\\n](.{12})\\s{2}(.{8})\\s(.{8})[\\r\\n](.{31})[\\r\\n]\\s*(\\S*)\\s*P#(.{12})[\\r\\n](.{31})[\\r\\n].*[\\r\\n]\\s*(\\S*)[\\r\\n]\\s*(\\S*)\\s*(\\S*).*[\\r\\n].*[\\r\\n]\\s*(\\S*)\\s*(\\S*).*[\\r\\n]\\s*(\\S*)\\s*(\\S*).*[\\r\\n]\\s*(\\S*)\\s*(\\S*).*[\\r\\n]\\s*(\\S*)\\s*(\\S*)\\s*(\\S*).*[\\r\\n]\\s*(\\S*).*[\\r\\n]\\s*(.{12}).*[\\r\\n](.{19}).*[\\r\\n].*', 'gm')
const str = `201
541-303-1291 05/28/20 13:29:55
MUNSELL,MAJORIE
865 P#541-303-1291
W RIDGEWAY AVE
ESN=06204
HERMISTON OR
CLASS:RESD TEL=CHTR
LAT: LON:
METERS: PERCENT:
ELV SPD DIR
PSAP=HERM
HERMISTON PD
UMATILLA COUNTY FD1
UMATILLA COUNTY FD1 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}