package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)2(\d{2})[\r\n](.{12})\s{2}(.{8})\s(.{8})[\r\n](.{31})[\r\n]\s*(\S*)\s*P#(.{12})[\r\n](.{31})[\r\n].*[\r\n]\s*(\S*)[\r\n]\s*(\S*)\s*(\S*).*[\r\n].*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*).*[\r\n]\s*(.{12}).*[\r\n](.{19}).*[\r\n].*`)
var str = `201
541-303-1291 05/28/20 13:29:55
MUNSELL,MAJORIE
865 P#541-303-1291
W RIDGEWAY AVE
ESN=06204
HERMISTON OR
CLASS:RESD TEL=CHTR
LAT: LON:
METERS: PERCENT:
ELV SPD DIR
PSAP=HERM
HERMISTON PD
UMATILLA COUNTY FD1
UMATILLA COUNTY FD1 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}