// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)2(\d{2})[\r\n](.{12})\s{2}(.{8})\s(.{8})[\r\n](.{31})[\r\n]\s*(\S*)\s*P#(.{12})[\r\n](.{31})[\r\n].*[\r\n]\s*(\S*)[\r\n]\s*(\S*)\s*(\S*).*[\r\n].*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*).*[\r\n]\s*(.{12}).*[\r\n](.{19}).*[\r\n].*").unwrap();
let string = "201
541-303-1291 05/28/20 13:29:55
MUNSELL,MAJORIE
865 P#541-303-1291
W RIDGEWAY AVE
ESN=06204
HERMISTON OR
CLASS:RESD TEL=CHTR
LAT: LON:
METERS: PERCENT:
ELV SPD DIR
PSAP=HERM
HERMISTON PD
UMATILLA COUNTY FD1
UMATILLA COUNTY FD1 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}