use strict;
my $str = '201
541-303-1291 05/28/20 13:29:55
MUNSELL,MAJORIE
865 P#541-303-1291
W RIDGEWAY AVE
ESN=06204
HERMISTON OR
CLASS:RESD TEL=CHTR
LAT: LON:
METERS: PERCENT:
ELV SPD DIR
PSAP=HERM
HERMISTON PD
UMATILLA COUNTY FD1
UMATILLA COUNTY FD1 ';
my $regex = qr/2(\d{2})[\r\n](.{12})\s{2}(.{8})\s(.{8})[\r\n](.{31})[\r\n]\s*(\S*)\s*P#(.{12})[\r\n](.{31})[\r\n].*[\r\n]\s*(\S*)[\r\n]\s*(\S*)\s*(\S*).*[\r\n].*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*).*[\r\n]\s*(.{12}).*[\r\n](.{19}).*[\r\n].*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}