#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)2(\d{2})[\r\n](.{12})\s{2}(.{8})\s(.{8})[\r\n](.{31})[\r\n]\s*(\S*)\s*P#(.{12})[\r\n](.{31})[\r\n].*[\r\n]\s*(\S*)[\r\n]\s*(\S*)\s*(\S*).*[\r\n].*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*)\s*(\S*)\s*(\S*).*[\r\n]\s*(\S*).*[\r\n]\s*(.{12}).*[\r\n](.{19}).*[\r\n].*"
Local $sString = "201" & @CRLF & _
"541-303-1291 05/28/20 13:29:55" & @CRLF & _
"MUNSELL,MAJORIE " & @CRLF & _
" 865 P#541-303-1291" & @CRLF & _
"W RIDGEWAY AVE " & @CRLF & _
" " & @CRLF & _
" ESN=06204" & @CRLF & _
"HERMISTON OR" & @CRLF & _
"" & @CRLF & _
"CLASS:RESD TEL=CHTR " & @CRLF & _
"LAT: LON: " & @CRLF & _
"METERS: PERCENT: " & @CRLF & _
"ELV SPD DIR " & @CRLF & _
"PSAP=HERM" & @CRLF & _
"HERMISTON PD" & @CRLF & _
"UMATILLA COUNTY FD1" & @CRLF & _
"UMATILLA COUNTY FD1 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")