import Foundation
let pattern = #"^\w+([.-]?\w+)*@\w+([.-]?\w+)*(\.\w{2,})+$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Examples of what passes/fails this Regex:
one@send.co
one@send.io
one@send.com
one.two@send.com
one.two.three@send.com
_one@send.com
one@send_it_.com
one-two@send-it.com
123@send.com
-one@send.com
one-@send.com
one@-send.com
one@send-.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)