# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\w+([.-]?\w+)*@\w+([.-]?\w+)*(\.\w{2,})+$"
test_str = ("Examples of what passes/fails this Regex:\n"
"one@send.co\n"
"one@send.io\n"
"one@send.com\n"
"one.two@send.com\n"
"one.two.three@send.com\n"
"_one@send.com\n"
"one@send_it_.com\n"
"one-two@send-it.com\n"
"123@send.com\n"
"-one@send.com\n"
"one-@send.com\n"
"one@-send.com\n"
"one@send-.com")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.