// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\w+([.-]?\w+)*@\w+([.-]?\w+)*(\.\w{2,})+$").unwrap();
let string = "Examples of what passes/fails this Regex:
one@send.co
one@send.io
one@send.com
one.two@send.com
one.two.three@send.com
_one@send.com
one@send_it_.com
one-two@send-it.com
123@send.com
-one@send.com
one-@send.com
one@-send.com
one@send-.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}