re = /^\w+([.-]?\w+)*@\w+([.-]?\w+)*(\.\w{2,})+$/m
str = 'Examples of what passes/fails this Regex:
one@send.co
one@send.io
one@send.com
one.two@send.com
one.two.three@send.com
_one@send.com
one@send_it_.com
one-two@send-it.com
123@send.com
-one@send.com
one-@send.com
one@-send.com
one@send-.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end