#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w+([.-]?\w+)*@\w+([.-]?\w+)*(\.\w{2,})+$"
Local $sString = "Examples of what passes/fails this Regex:" & @CRLF & _
"one@send.co" & @CRLF & _
"one@send.io" & @CRLF & _
"one@send.com" & @CRLF & _
"one.two@send.com" & @CRLF & _
"one.two.three@send.com" & @CRLF & _
"_one@send.com" & @CRLF & _
"one@send_it_.com" & @CRLF & _
"one-two@send-it.com" & @CRLF & _
"123@send.com" & @CRLF & _
"-one@send.com" & @CRLF & _
"one-@send.com" & @CRLF & _
"one@-send.com" & @CRLF & _
"one@send-.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")