import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w+([.-]?\\w+)*@\\w+([.-]?\\w+)*(\\.\\w{2,})+$";
final String string = "Examples of what passes/fails this Regex:\n"
+ "one@send.co\n"
+ "one@send.io\n"
+ "one@send.com\n"
+ "one.two@send.com\n"
+ "one.two.three@send.com\n"
+ "_one@send.com\n"
+ "one@send_it_.com\n"
+ "one-two@send-it.com\n"
+ "123@send.com\n"
+ "-one@send.com\n"
+ "one-@send.com\n"
+ "one@-send.com\n"
+ "one@send-.com";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}