package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w+([.-]?\w+)*@\w+([.-]?\w+)*(\.\w{2,})+$`)
var str = `Examples of what passes/fails this Regex:
one@send.co
one@send.io
one@send.com
one.two@send.com
one.two.three@send.com
_one@send.com
one@send_it_.com
one-two@send-it.com
123@send.com
-one@send.com
one-@send.com
one@-send.com
one@send-.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}