using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w+([.-]?\w+)*@\w+([.-]?\w+)*(\.\w{2,})+$";
string input = @"Examples of what passes/fails this Regex:
one@send.co
one@send.io
one@send.com
one.two@send.com
one.two.three@send.com
_one@send.com
one@send_it_.com
one-two@send-it.com
123@send.com
-one@send.com
one-@send.com
one@-send.com
one@send-.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}