import Foundation
let pattern = #".+{x\=([0-9\.]+)\s*y\=([0-9\.]+).+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"0x0000023646b21750 {x=0.74999899999999997 y=0.91666399999999992 index=69 ...}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"($1, $2)"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)